I tried to install snappy compression with MapR following the steps in :

http://code.google.com/p/hadoop-snappy/ previously installing the native library from : http://code.google.com/p/snappy/

and Jobtracker and tasktrackers manage to detect it and load it , but when they try to use it in a sequence file then fails abruptely :

2012-03-21 10:40:43,404 FATAL org.apache.hadoop.mapred.Child: Error running child : java.lang.UnsatisfiedLinkError: org.apache.hadoop.io.compress.snappy.SnappyCompressor.compressBytesDirect()I at org.apache.hadoop.io.compress.snappy.SnappyCompressor.compressBytesDirect(Native Method) at org.apache.hadoop.io.compress.snappy.SnappyCompressor.compress(SnappyCompressor.java:229) at

It seems a problem concerning native library loading.Is anyone facing this problem about hadoop-snappy native library ?

I tried to patch hadoop-snappy with this : http://code.google.com/p/hadoop-snappy/issues/detail?id=6 but doesn't compile (RTL_DEFAULT symbol missing).

Thanks

asked 21 Mar '12, 03:55

epalace's gravatar image

epalace
1222
accept rate: 0%


Hi,

Please upgrade to v.1.2.3 (http://package.mapr.com/releases/v1.2.3/) and follow instructions from http://code.google.com/p/hadoop-snappy/ .

It should work.

link

answered 22 Mar '12, 18:56

amit's gravatar image

amit ♦
41415
accept rate: 56%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×22
×3
×3

Asked: 21 Mar '12, 03:55

Seen: 2,168 times

Last updated: 22 Mar '12, 18:56

powered by OSQA