This issue is related to the M3 install. I get this error when running the following command:

/opt/mapr/bin/maprcli acl edit -type cluster -user mapr_user:fc
ERROR (10009) -  Couldn't connect to the CLDB service

I have read tried to resolve it with the solution from a M5 install with no success. http://answers.mapr.com/questions/184/after-install-m5-cannot-connect-to-cldb-and-mapr-control-system-not-up

I have tried using IPs and starting zookeeper in reverse order(node 3, 2, 1) and still get the same message: ERROR (10009) - Couldn't connect to the CLDB service

The /opt/mapr/logs/cldb.log shows repetition of the following message:

prog: 2345, proc 103, RpcProgram not found
prog: 2345, proc 40, RpcProgram not found
2011-08-12 15:18:29,391 INFO  com.mapr.fs.cldb.zookeeper.ZooKeeperClient [main]: Waiting for local KvStoreContainer to become valid. KvStore ContainerInfo  Container ID:1 Master:10.12.8.181:5660--5-VALID(8332614808256269759) Servers:  10.12.8.181:5660--5-VALID(8332614808256269759) 10.12.8.182:5660--5-VALID(8103253192155637236) 10.12.8.184:5660--5-VALID(1316527993516468479) Inactive Servers:  Unused Servers:  Latest epoch:5 SizeMB:0 CLDB ServerID : 318999943305798534
2011-08-12 15:18:32,393 INFO  com.mapr.fs.cldb.zookeeper.ZooKeeperClient [main]: Waiting for local KvStoreContainer to become valid. KvStore ContainerInfo  Container ID:1 Master:10.12.8.181:5660--5-VALID(8332614808256269759) Servers:  10.12.8.181:5660--5-VALID(8332614808256269759) 10.12.8.182:5660--5-VALID(8103253192155637236) 10.12.8.184:5660--5-VALID(1316527993516468479) Inactive Servers:  Unused Servers:  Latest epoch:5 SizeMB:0 CLDB ServerID : 318999943305798534
prog: 2345, proc 103, RpcProgram not found
prog: 2345, proc 40, RpcProgram not found

Thanks in advance if anyone has any suggestion for this fix.

asked 12 Aug '11, 15:26

meetom's gravatar image

meetom
6111
accept rate: 0%

edited 15 Aug '11, 11:51

TedDunning's gravatar image

TedDunning ♦♦
3.6k322


From the log it looks like you installed packages (, uninstalled ) and reinstalled them again? For some reason you have bad state in ZooKeeper and you ended up in this situation. If it is fresh install can you clear ZooKeeper state and re-install the package and start them. Information about ZooKeeper cleaner can be found here

link

answered 15 Aug '11, 11:46

Lohit's gravatar image

Lohit ♦♦
2.1k313
accept rate: 44%

Can you provide more information about your cluster? How many nodes, which operating system, where you are running each service, and so on.

link

answered 14 Aug '11, 21:05

Peter%20Conrad's gravatar image

Peter Conrad ♦♦
926237
accept rate: 27%

Cluster works now for Tom. He did reinstallation and forgot to clean up ZK data, exactly what Lohit explained. Tom was able to clean nodes, reinstall MapR fresh and add M3 license. He is in a good shape now and started his testing.

link

answered 15 Aug '11, 13:52

lfedotov's gravatar image

lfedotov ♦♦
201124
accept rate: 27%

do I need to clean the zk data from each node?

(23 Nov '11, 16:00) Kas

Yes, you need to do this on all ZK nodes.

(23 Nov '11, 16:03) lfedotov ♦♦

And make sure that you stop all the ZK services before trying to clean up. Otherwise, ZK will simply consider your efforts to be something to be fixed and will recover the old data.

(23 Nov '11, 16:07) TedDunning ♦♦

How do I exactly clean the zk data from the zk nodes? The link provided above directs to a dead page. Also, if I am uninstalling mapR, does the yum erase automatically remove the zk data?

(29 Nov '11, 13:34) Kas

script to clean up that data is: /opt/mapr/server/zkdatacleaner.sh (data is located at /var/mapr--zookeeper-data directory) yum erase does not remove data, only software.

(29 Nov '11, 17:54) yufeldman ♦♦
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×137
×32
×5

Asked: 12 Aug '11, 15:26

Seen: 4,764 times

Last updated: 29 Nov '11, 17:57

powered by OSQA